Проблемы с подключением платы

popaslona13
Offline
Зарегистрирован: 13.01.2021

Здравствуйте Дорогие форумчане! 

У меня есть проблема с подключением платы ардуино уно. Как только я подключаю плату к компьютеру на пк полностью отключается звук, у меня есть предположение что это может происходить из за конфликта портов.

Помогите пожалуйста решить мою проблему заранее спасибо

mykaida
mykaida аватар
Offline
Зарегистрирован: 12.07.2018

Посмотрите в диспетчере устройств чего там с чем конфликтует.

rkit
Offline
Зарегистрирован: 23.11.2016

Питание совсем плохо. Или винда убитая.

GAMON
Offline
Зарегистрирован: 03.07.2017

 Подключаю Mega2560 - не работает опция "Инструменты>порт". Невозможно выбрать порт - он серый; не активный. Переустановил IDE - то же самое. 
Комп под Win10

 

andriano
andriano аватар
Offline
Зарегистрирован: 20.06.2015

А установить драйвер не судьба?

GAMON
Offline
Зарегистрирован: 03.07.2017

andriano пишет:

А установить драйвер не судьба?

Драйвер для какого устройства?

 

 

negavoid2
Offline
Зарегистрирован: 06.05.2020

Драйвер для Arduino, а точнее, для usb-uart.

Jeka_M
Jeka_M аватар
Offline
Зарегистрирован: 06.07.2014

popaslona13 пишет:

у меня есть предположение что это может происходить из за конфликта портов.

Каких портов?

GAMON
Offline
Зарегистрирован: 03.07.2017

andriano пишет:

А установить драйвер не судьба?


действительно - упустил момент, что это другой комп, и нет драйвера для 340-й. Глаз замылился на том, что прошился загрузчик через USBasp. Выдал список ругательств - но прошил. Странно другое - саму программу через USBasp загрузить

не удалось

GAMON
Offline
Зарегистрирован: 03.07.2017

 В моем девайсе установлен резонатор на 16,384. Это может быть проблемой для записи программы в среде ArduinoIDE?

 

 

andriano
andriano аватар
Offline
Зарегистрирован: 20.06.2015

GAMON пишет:

 В моем девайсе установлен резонатор на 16,384. Это может быть проблемой для записи программы в среде ArduinoIDE?

Ну, вообще-то это отличается от того, что нужно, примерно в 1000 раз, если Вы используете числовую запись характерную для английского языка или в 1000000 раз - если для русского. При условии, что "девайс" - это AVR.

b707
Offline
Зарегистрирован: 26.05.2017

GAMON пишет:

 В моем девайсе установлен резонатор на 16,384. Это может быть проблемой для записи программы в среде ArduinoIDE?

вряд ли

anatoli_nik
Offline
Зарегистрирован: 17.01.2019

Адриано, иди почитай про маркировку кварцевых резонаторов!

Цитата:
В моем девайсе установлен резонатор на 16,384. Это может быть проблемой для записи программы в среде ArduinoIDE?

Через загрузчик (по UARTу) в принципе работать должно, частота кварца не сильно отличается от 16,000, но нужно считать какая ошибка бодрейта.

Через внешний программатор прошивка должна проходить однозначно, если с фьюзами не натупили.

GAMON
Offline
Зарегистрирован: 03.07.2017

anatoli_nik пишет:

Адриано, иди почитай про маркировку кварцевых резонаторов!

Цитата:
В моем девайсе установлен резонатор на 16,384. Это может быть проблемой для записи программы в среде ArduinoIDE?

Через загрузчик (по UARTу) в принципе работать должно, частота кварца не сильно отличается от 16,000, но нужно считать какая ошибка бодрейта.

Через внешний программатор прошивка должна проходить однозначно, если с фьюзами не натупили.


C фьюзами пока не разобрался. Загрузчик я записал непосредственно из IDE, установленной на свежем ноуте под Win10. Странное дело - не нашел папку hardware. На старом компе под win7 такая папка есть - но там bootload только под 1280
На 115200 с резонатором на 16.384 погрешность даже меньше, чем на 16.000