реле не работает с ардуино

SLKH
Offline
Зарегистрирован: 17.08.2015

Lubitel пишет:

К сожелению схему нарисовать не кому. ........... Попробую пообщаться с продавцом по этому поводу. 

не позорься.

xDriver
xDriver аватар
Offline
Зарегистрирован: 14.08.2015

Lubitel пишет:

К сожелению схему нарисовать не кому. Реле выключается но когда высокий сигнал подаешь 4В. И я тоже подумал, что реле какоето бракованное. Попробую пообщаться с продавцом по этому поводу. О результатах обязательно отпишусь.

еперный театр, сколько-же можно схему этого и подобных реле постить в разных темах ?

Lubitel
Offline
Зарегистрирован: 08.01.2019

перемычки у себя не вижу. по маркировкам врое оно.

xDriver
xDriver аватар
Offline
Зарегистрирован: 14.08.2015

ну значит в вашем случае реле на 5 вольт и перемычка "по умолчанию".

Гриша
Offline
Зарегистрирован: 27.04.2014

со схемой самого реле понятно, проблема вроде тоже понятна... а куда скетч грузите и как esp8266 подключина (на какие пины)??? просто по сути вопросса при подаче питания на выбраную ногу управления при старте загрузчика приходит низкий уравень. Вариант лечения проблемы - поменять загрузчик или вообще грузить скетч в МК через ISP это вообще убивает загрузчик.

Это если я правильно проблему понял... и хотелось бы услышать про питание немного подробнее, что откуда и как питается, есть ли преобразователь уровней (как подключен, включая его питание если оно есть)

короче: нужна полноценная текущая схема подключения модулей. 

xDriver
xDriver аватар
Offline
Зарегистрирован: 14.08.2015

как вяжется esp8266 и ISP ?

начинаю ванговать, человек пытается дергать 13 пином и думаю не подозревает, что IO13 и пин 13 не одно и тоже на esp8266.

если оставить реле на IO13, а в коде дергать 7 пин может чего и срастется ?

Гриша
Offline
Зарегистрирован: 27.04.2014

xDriver пишет:

если оставить реле на IO13, а в коде дергать 7 пин может чего и срастется ?

схама будет, узнаем, а так только и ваговать, до хрустальные шары протирать... которые Клапа забанил на этом сайте.

Lubitel
Offline
Зарегистрирован: 08.01.2019

Все добрый вечер. Благодарю за идеи. Общался с поставщиком реле. Вот его ответ: "Да, 3.3 вольта  - маловато. Как вариант, можно изменить номинал резистора в цепи оптопары. Чтобы светодиод оптопары светил ярче. Прямо поверх него, параллельно припаять резистор на 100 Ом, к примеру. Ну а если делать красиво, то нужно между ESP и любыми 5-вольтовыми устройствами ставить преобразователь уровней." По поводу подключения - подключал пин 13 и пин 16 результат аналогичный. питание от пинов GND и USB. сама плата подключена от ноутбука шнурком мини usb.

Lubitel
Offline
Зарегистрирован: 08.01.2019

В итоге продавец посаветовал найти модуль реле с 3,3 В логикой или поставить преобразователь уровней или полевой транзистор на выходе с ESP. Сейчас разбираюсь с транзистором. Тему наверно можно считать закрытой. Всем огромное спасибо за советы.

achuser
Offline
Зарегистрирован: 02.03.2013

Господа, прошу помощи, ибо в электронике я не силен, полдня проколупался без успехов :) 

Суть проблемы: есть некая плата с индикацией режима работы через светодиоды. Необходимо снять сигнал одного из режимов, т.к. светодиоды там полноразмерные, не смдшки, то логично не заморачиваясь брать его оттуда. Но вот беда в том, что походу свечение их идет через ШИМ. Казалось бы - раз светодиод горит, то и готовый релейный модуль с оптопарой не проблема запустить, но вот на деле - светодиод горит на модуле, а реле не срабатывает. Пробовал убирать светодиод, чтобы на оптрон больше ток приходил, но не помогает. Пробовал модуль на транзисторе, без оптрона - диод горит, реле дребезжит. Ставил конденсаторы между входом и питанием 0.1 керамику и пробовал элеткролит 1 мкф, думал сгладит импульсы, но результата ноль. 

В какую сторону копать? Мог бы предположить, что проблема в управлении реле по минусу, а не плюсу, но какая разница, если светодиод индикации стоит последовательно с оптроном и по идее он, наверное еще прожорливее, нежели в самом оптроне... 

простым RC - фильтром с резистором 50-100 ком и конденсатором 0.1 мкф удалось увидеть цэшкой 0.7В стабильных. Выше поднять не получилось, либо нужны кардинально иное сочетание номиналов... 

 

nik182
Offline
Зарегистрирован: 04.05.2015

achuser пишет:

0-100 ком и конденсатором 0.1 мкф удалось увидеть цэшкой 0.7В стабильных. Выше поднять не получилось, либо нужны кардинально иное сочетание номиналов... 

100 Ом, диод и 10 мкф электролит помогут.   

achuser
Offline
Зарегистрирован: 02.03.2013

nik182 пишет:

achuser пишет:

0-100 ком и конденсатором 0.1 мкф удалось увидеть цэшкой 0.7В стабильных. Выше поднять не получилось, либо нужны кардинально иное сочетание номиналов... 

100 Ом, диод и 10 мкф электролит помогут.   

 

Спасибо, поэксперементирую... 

Но крайне интересно, почему реле с оптроном не работает? Ведь частота шим спокойно питает светодиоды без какого-либо мерцания для глаза, значит и светодиод оптопары должен открывать транзистор? Тем более, что индикационный светодиод на плате загорается.

Гриша
Offline
Зарегистрирован: 27.04.2014

achuser пишет:

Спасибо, поэксперементирую... 

Но крайне интересно, почему реле с оптроном не работает? Ведь частота шим спокойно питает светодиоды без какого-либо мерцания для глаза, значит и светодиод оптопары должен открывать транзистор? Тем более, что индикационный светодиод на плате загорается.

Без минимальной схемы по существу вопроса ответить не реально, к этому еще и некоторые эксперименты потребуются, раз уж нет осциллографа. 

вот вам никто ничего и не пишет - трудно гадать, вроде все верно описываете, но раз не получается -  рисуйте схему. 

rkit
Offline
Зарегистрирован: 23.11.2016

achuser пишет:

Казалось бы - раз светодиод горит, то и готовый релейный модуль с оптопарой не проблема запустить

Казалось бы - вот идиоты, учатся по нескольку лет, схемы рисуют, читают учебники толстые со скучными формулами, работают над одним прибором по нескольку месяцев по 8 часов в день. Возьму сейчас, измерю напряжение на выходе динамической индикации, реле подключу по непонятно какой схеме, поставлю конденсатор непонятно куда и зачем, и не проблема.

achuser
Offline
Зарегистрирован: 02.03.2013

rkit пишет:

Казалось бы - вот идиоты, учатся по нескольку лет, схемы рисуют, читают учебники толстые со скучными формулами, работают над одним прибором по нескольку месяцев по 8 часов в день. Возьму сейчас, измерю напряжение на выходе динамической индикации, реле подключу по непонятно какой схеме, поставлю конденсатор непонятно куда и зачем, и не проблема.

Никогда не понимал людей, у которых достаточно времени на сотни комментариев не по существу вопроса. Нечего сказать - так зачем тратить свое драгоценное время и время читателей? Потом полезной информации на форумах не найдешь из-за подобного флуда. Если бы все были радио инженерами и учились по 5 лет в этом направлении, то подобного рода форумов бы и не существовало! А если это не Ваш уровень знаний и желания помогать дельными советами нет - зачем тратите свое время на просмотр этих тем и написание г..постов? Реально не могу понять таких людей, которые пытаются из себя что-то строить и утверждаться в сети подобным образом.

 

По существу вопроса: схемы устройства найти не реально, какой-либо информации в сети по нему найти не удалось, но кто понимает в этом, наверное из описание суть ясна, вряд ли там большой разброс по частоте возможен, раз известно какая нагрузка применена (светодиод). Устройство - клапан Runxin для колонн водоподготовки, необходимо открывать клапан при одном из режимов промывки колонны.

Пробовал зацепить 817 оптрон напрямую с выводов - однако, он реально не открывает транзистор. Собрал фильтр на электролите с диодом, как выше было предложено. Вольтметр увидел до 4+ вольт. Но вот есть опять нюанс: оптрон через этот фильтр имеет сопротивление Э-К порядка 2.3 кОм, вместо ~60 Ом. Значит засветка идет с пульсациями и базу дергает? Или в чем причина?

 

 

nik182
Offline
Зарегистрирован: 04.05.2015

От 4 вольт оптрон должен срабатывать. Как Вы умудряетесь мерить его сопротивление? Он штука нелинейная и до момента зажигания почти разрыв, потом почти стабилитрон на напряжение свечения.

rkit
Offline
Зарегистрирован: 23.11.2016

achuser пишет:

Никогда не понимал людей, у которых достаточно времени на сотни комментариев не по существу вопроса. Нечего сказать - так зачем тратить свое драгоценное время и время читателей?

Попробуй еще раз прочитать, что написано. Там полный список твоих ошибок.  Если напрячь мозги и начать их исправлять, то что-нибудь и получится. А пока драгоценное время читателей тратишь как раз ты.

achuser
Offline
Зарегистрирован: 02.03.2013

nik182 пишет:
От 4 вольт оптрон должен срабатывать. Как Вы умудряетесь мерить его сопротивление? Он штука нелинейная и до момента зажигания почти разрыв, потом почти стабилитрон на напряжение свечения.

в момент засветки светодиода сопротивление между выводами 3 и 4 оптрона становится равным около 60 Ом, +- в зависимости от транзистора в нем.  В принципе, что и случается при подаче питания с обычного источника. А так, когда закрыт, то конечно, сопротивление там свыше 200 кОм в одну сторону и условно бесконечность в другую. 

Но при подключении через фильтр, сопротивление открытого транзистора далеко не омы, а свыше 2 кОм. 

Либо все же светодиод горит в пол накала, либо ток пульсирует и ему опять же не хватает. Но вообще, от этого фильтра уже можно запитать реле, и тока даже хватает дернуть катушку реле, в момент,когда конденсатор максимально заряжен. Поддерживать включенное состояние, конечно, не удается, но факт в том, что и транзистор и оптрон уже способен дернуть нечто с отдельным питанием. 

Вообще есть у кого мысли, почему светодиод оптрона не горит от этого источника, от которого светятся обычные светодиоды? По даташиту ток светодиода 50мА. Ток свечения индикаторных светодиодов 5-20мА. Может в нем реально стоит нечто жрущее, чему просто не хватает тока для засветки фототранзистора? При этом обычным светодиодам тока за глаза?

 

SLKH
Offline
Зарегистрирован: 17.08.2015

achuser пишет:

Вообще есть у кого мысли, 

#63

nik182
Offline
Зарегистрирован: 04.05.2015

У меня у оптрона ток срабатывания 5-7 мА. По мануалу 50. Обычно подбираю резистор под 10 мА.     

Если внутри блока из которого выходит ШИМ есть ограничивающий резистор, да ещё внешний резистор, то может быть всё что угодно. Увеличьте емкость до 100мкф , а резистор вообще уберите, если внутри есть ограничивающий резистор.  

Гриша
Offline
Зарегистрирован: 27.04.2014

nik182 пишет:

У меня у оптрона ток срабатывания 5-7 мА. По мануалу 50. Обычно подбираю резистор под 10 мА.     

Если внутри блока из которого выходит ШИМ есть ограничивающий резистор, да ещё внешний резистор, то может быть всё что угодно. Увеличьте емкость до 100мкф , а резистор вообще уберите, если внутри есть ограничивающий резистор.  

где схема, какое падение на диоде, какой диод, какое сопротивление , какое напряжение, это прямой выход с МК или стоит еще что-то??????????????????

Я свой хрустальный шар потерял

на худой конец прицепить ардуинку АЦП на диод и циклом снять 10 измерений подряд, а потом их выкинуть в порт, коды сюда, с указанием используемой опоры. 

achuser
Offline
Зарегистрирован: 02.03.2013

Задача решена RC фильтром перед оптроном, несмотря на высокое сопротивление перехода Э-К, этого достаточно, чтобы открыть силовой транзистор. В фильтре резисторы ставить не стал ибо ток на входе уже рассчитан под диод, оптрон холодный, все норм.

А вопрос то был не в токоограничивающих резисторах с выхода МК и тп, вопрос стоит в том - какие характеристики могут влиять на то, что обычный индикаторный светодиод ярко горит с выхода ШИМ и даже не один, т.е. тока там не менее 20 мА, а светодиод оптрона нет, хотя как выше и подтверждают, что ему достаточно до 10 мА для стабильной работы.