arduino nano не определяется mac

liskior
Offline
Зарегистрирован: 04.11.2017

Всем привет! Заказала несколко arduino nano v3 у китайцев, а они не определяются компом, список портов пуст:( Горит зеленый диодик on, и мигает синий L. Дрова сh340g и fdti поставила. С arduino uno проблем нет. Что делать и кто виноват?:(

Гриша
Offline
Зарегистрирован: 27.04.2014

сколько разъемов USB на компе? не тыкивать плату в тот разъем где воткнута УНА.  какие устройства появились после "втыкивания" ???

:)))))))))))))))))))))))))))))))))

 

bwn
Offline
Зарегистрирован: 25.08.2014

Гриша пишет:

сколько разъемов USB на компе? не тыкивать плату в тот разъем где воткнута УНА.  

А в чем здесь проблема? У меня и унка с FTDI и переходник с 340 без проблем с одного порта. Точнее, когда в какой подключится.

Гриша
Offline
Зарегистрирован: 27.04.2014

bwn пишет:

А в чем здесь проблема? У меня и унка с FTDI и переходник с 340 без проблем с одного порта. Точнее, когда в какой подключится.

в таком разе мне приходится порты в ИДЭ руками выбирать, а это 2 клика мыши. если УСБ разные - программа сама понимает какой порт и ничего выбирать не нужно :))))))))))))))))))))))))))) не разбирался в чем прикол, просто помню и пользую.

ЗЫ основной вопрос во второй части поста.

Jeka_M
Jeka_M аватар
Offline
Зарегистрирован: 06.07.2014

Цитата:

arduino nano не определяется mac

При чём здесь MAC? Это называется виртуальный COM-порт. 

Цитата:

список портов пуст

Что видно в диспетчере устройств? При  подключении ардуины должен либо появиться новый COM-порт (драйвера установлены правильно), либо неизвестное устройство со знаком вопроса (драйвера установлены неправильно или вообще не уствновлены).

Если в диспетчере устройств вообще ничего не появляется, значит неисправна ардуина (точнее USB-UART преобразоваатель CH340). Кстати, нужно точно знать, какой там стоит преобразователь - FT232RL или CH340, поэтому внимательно посмотрите на маркировку микросхемы.

b707
Offline
Зарегистрирован: 26.05.2017

liskior пишет:

Всем привет! Заказала несколко arduino nano v3 у китайцев, а они не определяются компом, список портов пуст:( Горит зеленый диодик on, и мигает синий L. Дрова сh340g и fdti поставила. С arduino uno проблем нет. Что делать и кто виноват?:(

попробуйте на другом компе, лучше на винде - если определятся. значит проблема в компе, если нет - в плате

liskior
Offline
Зарегистрирован: 04.11.2017

Гриша пишет:

сколько разъемов USB на компе? не тыкивать плату в тот разъем где воткнута УНА.  какие устройства появились после "втыкивания" ???

:)))))))))))))))))))))))))))))))))

 

 

Перепробовала все порты, ничего не появляется вообще:(

liskior
Offline
Зарегистрирован: 04.11.2017

Jeka_M пишет:

Цитата:

arduino nano не определяется mac

При чём здесь MAC? Это называется виртуальный COM-порт. 

mac - не адрес, а макбук, может быть важно для определения проблемы или чтобы люди не тратили время, расписывая решение для винды

Jeka_M пишет:

Цитата:

список портов пуст

Что видно в диспетчере устройств? При  подключении ардуины должен либо появиться новый COM-порт (драйвера установлены правильно), либо неизвестное устройство со знаком вопроса (драйвера установлены неправильно или вообще не уствновлены).

Если в диспетчере устройств вообще ничего не появляется, значит неисправна ардуина (точнее USB-UART преобразоваатель CH340). Кстати, нужно точно знать, какой там стоит преобразователь - FT232RL или CH340, поэтому внимательно посмотрите на маркировку микросхемы.

не появляется вообще ничего, преобразователь CH340. Получается вообще ничего сделать нельзя?:(

Jeka_M
Jeka_M аватар
Offline
Зарегистрирован: 06.07.2014

Сорри, не сразу понял, что речь идёт про макбук. Тогда не подскажу, я маками не пользуюсь. Единственное, что могу посоветовать - найти ноутбук или комп с виндой и там попробовать. Чтобы точно определиться - проблема с самой платой ардуино или с маком (драйверами).

Гриша
Offline
Зарегистрирован: 27.04.2014

да походу кабель битый или платка брак (недавно кто-то про сопли писал, лазил с лупой и чистил между ног), даже МАС чего-нибудь да нарисовал бы... аналогично флешки при первом включении

liskior
Offline
Зарегистрирован: 04.11.2017

Всем спасибо, сегдня проверила на винде - работает 1 из 5 ардуинок, у остальных даже разъем другой, хотя все вроде nano v3 - это нормально вообще? И еще проблема, почему-то стал мгновенно выключаться мак при подсоединении любой nano, может кто-то сталкивался? Страшновато за него:(

b707
Offline
Зарегистрирован: 26.05.2017

liskior пишет:

Всем спасибо, сегдня проверила на винде - работает 1 из 5 ардуинок, у остальных даже разъем другой, хотя все вроде nano v3 - это нормально вообще? И еще проблема, почему-то стал мгновенно выключаться мак при подсоединении любой nano, может кто-то сталкивался? Страшновато за него:(

разъемы могут быть разные - мини- или микро-УСБ - это нормально. А то что комп выключается при подсоединении ардуины - не нормально.

Совет - не выеживайтесь, пользуйте винду :))))

irek_habi
irek_habi аватар
Offline
Зарегистрирован: 26.12.2018

взял только что у товарища китайские ардуинки nano поиграться. у самого macbook air 13 (mid). все драйвера вроде как скачал. вощем есть nano с чипом atmega328 и с чипом atmega168. первая подключается без проблем, и скетчи загружаюся и все радужно вроде как. а вторая сначала вообще не подключалсь, потом после отключения 328-ой 168-ая волшебным образом подключилась. я радостно начал заливать скетч, вышла ошибка. не успел я дочитать ошибку, как дисплей мака выключился и вышла какая-то страшная системная ошибка. мак перезагрузил, но 168 ардуина больше не обнаруживается. а самое странное, что скетч на 168 все-таки встал. сейчас думаю, может попробовать бутлодер перепрошить.

Altcms
Altcms аватар
Offline
Зарегистрирован: 17.09.2017

 irek_habi  Проблема в драйвете для CH340, довольно известная. На 10.11 и выше просто ошибка и перезагрузка,поставить новые дрова и проблема решаеться. Я ставил 1.5 работает без проблем. 

Брал тут https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver

irek_habi
irek_habi аватар
Offline
Зарегистрирован: 26.12.2018

до этого ставил версию 1.4 от того же разрабаотчика, так что без особого энтузиазма устанавливал версию 1.5. однако, все с точностью, как вы сказали: после установки 1.5 проблема сошла на нет, скетчи загружаются без проблем. Спасибо!

User112
Offline
Зарегистрирован: 11.01.2019

Добрый день

Аналогичная проблема - плата мега комп MacPro high sierra 10.13.4

Плата рабочая - протестирована на винде

Драйвер ch304 на комп установлен

При подключении в отчете системы появляется usb2.0 - serial

но в списке портов arduino ide его нет - только usb bluetooth-incoming port

кто сталкивался с аналогичной проблемой?

 

Гриша
Offline
Зарегистрирован: 27.04.2014

User112 пишет:

При подключении в отчете системы появляется usb2.0 - serial

но в списке портов arduino ide его нет -

не уверен, с МАСом не имел дел, возможно необходимо отключить VCP (виртуальный компорт) это в настройках этого самого "в отчете системы появляется usb2.0 - serial" необходимо поправить.

Jeka_M
Jeka_M аватар
Offline
Зарегистрирован: 06.07.2014

Не знаю как на маке, а на линуксе нужно добавить пользователя в группы tty и dialout.

User112
Offline
Зарегистрирован: 11.01.2019

в тот то и дело в группе tty он должен появиться после установке драйверов

сейчас удалось подключить китайские дрова - началась ошибка kernel panic

думать надо как удалить

 

Maka
Offline
Зарегистрирован: 24.10.2015

Altcms пишет:

 irek_habi  Проблема в драйвете для CH340, довольно известная. На 10.11 и выше просто ошибка и перезагрузка,поставить новые дрова и проблема решаеться. Я ставил 1.5 работает без проблем. 

Брал тут https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver

Качнул, ради прикола решил обновить дрова на CH340, но решил редми сначала почитать. Там в начале написано про удаление старых кекстов:

Remove the old driver by issuing one of the following commands (depending on your installation):

    * `sudo rm -rf /System/Library/Extensions/usb.kext`
    * `sudo rm -rf /Library/Extensions/usbserial.kext`
 
У меня в этой директории таких кекстов нет. Однако китайские ардуины шъются, так как я качал откуда-то драйвер, и да, были паники пока не нашел нужную версию. Загадка. Оставлю пока так как есть, работает и ладно.