Cреда ARDUINO выдает ошибк от launch4j "An error while starting the application"

kand
Offline
Зарегистрирован: 28.01.2014

При запуске среды ARDUINO 1.5.5, через 1-2 минуты выдает ошибку от launch4j "An error while starting the application".  Версия 1.5.2 ARDUINO вылетает даже не ругаясь ...... По диспетчеру задач видно идет загрузка , а потом вылетает .....  Попробовал поковыряться: JAVA установленная в системе  не запускает контрольную панель. Что делать? 

nikmih98
Offline
Зарегистрирован: 21.01.2014

Поставь Яву постарее или поновее, в зависимости от той, что у тебя стоит. У меня тоже такая хрень вылетает, но через несколько раз запускается.

kand
Offline
Зарегистрирован: 28.01.2014

Спасибо

Пока не помогает

Клапауций
Offline
Зарегистрирован: 10.02.2013

у меня какая-то из 1.5.* просто не запускалась - забил за ненабностью юзать бетки.

NE_XT
NE_XT аватар
Offline
Зарегистрирован: 22.05.2012

Странно , но последнюю неделю тоже стала вылетать эта ошибка, (Win8.1) , может какой апдейт подцепили мы?

Заметил на форумах стали спрашивать.....

kand
Offline
Зарегистрирован: 28.01.2014

Пока удалил все ссылки на JAVA  в реестре и все установленные файлы и папки, в том числе мусор, который нашел - не помогает. На офицальном сайте рекомендуют  отключить блютуз - тоже не помогло ... После неудачного зауска в системе остаются  невыгруженными  службы JAVA ...

kand
Offline
Зарегистрирован: 28.01.2014

Проблема решена:

Надо отключить шрифты ClearTypeс помощью соответсвующей программы в панели управления , если ее нет то можно скачать здесь : http://www.microsoft.com/typography/cleartypepowertoy.mspx

После установки снимаем галочку в ClearType и arduino.exe работает !

Не пробовал, но предлагают еще вместо установки программы изменить реестр:

Windows Registry Editor Version 5.00 
  [HKEY_CURRENT_USER\Control Panel\Desktop] 
 "FontSmoothingGamma"=dword:00000898

 

Клапауций
Offline
Зарегистрирован: 10.02.2013

kand пишет:

Проблема решена:

Надо отключить шрифты ClearTypeс помощью соответсвующей программы в панели управления , если ее нет то можно скачать здесь : http://www.microsoft.com/typography/cleartypepowertoy.mspx

После установки снимаем галочку в ClearType и arduino.exe работает !

так шрифты выпилить или сглаживание отключить?

*думаю, что они просто офигели - завтра на линукс попросят перейти или к яблоку в анальное рабство продаться.

kand
Offline
Зарегистрирован: 28.01.2014

Снять галочку - "Turn on ClearType"

Клапауций
Offline
Зарегистрирован: 10.02.2013

kand пишет:

Снять галочку - "Turn on ClearType"

это какой-то костыль.

как так без сглаживания жить?

kand
Offline
Зарегистрирован: 28.01.2014

Да, Да - причём в JAVA  

:)

std
Offline
Зарегистрирован: 05.01.2012

Народ, выручайте! Только вчера среда работала, сегодня эта херня.

С новой версией Java тупо вылет и никакая ошибка не показывается. Иногда среда грузится, но если открывать скетч - тут же крашится, работать невозможно. Что делать?

Andrey_Y_Ostanovsky
Offline
Зарегистрирован: 03.12.2012

std пишет:

Иногда среда грузится, но если открывать скетч - тут же крашится, работать невозможно. Что делать?

Откатить изменения? Или попробовать все то же самое на другой, заведомо исправной, системе: дело может быть не в среде, а, например, в сбоях по памяти...

std
Offline
Зарегистрирован: 05.01.2012

Показывается именно та ошибка что в названии темы. Так что это не связано с памятью. Тем не менее я попробую это на другой машине, но вылечить проблему на моей рабочей системе необходимо.

Найденные способы:

- в HKEY_CURRENT_USER\Control Panel\Desktop\FontSmoothingGamma поставить dword:00000898

- удалить каталог %mydocuments%\Arduino

- поменять версию Java в каталоге %arduino%\java

- поменять версию JRE вообще

- раскомментировать строку #settings.path=data в %arduino%\lib\preferences.txt

- отключить вайфай. на ноуте отключается по Fn+F2. держу отключенным, включаю только когда нужен

- отключить bluetooth. голубого зуба в самом ноуте нет, внешних адаптеров нет, ничто с BT не используется

Ничто не помогло. Качаю версии 1.0.6 и 1.5.8 с офсайта, результат отпишу только через несколько часов, и то над скачкой тенью навис замахнувший косу мрачный жнец - качается на скорости в единицы-десятки кбит/с, обрывы, лаги, хз что.

UPD. Да, а откатить что? Ничто в системе не менялось, не сносилось и не устанавливалось. Она, собсно, 18 суток даже не перезагружалась. Ну и откатить некуда т. к. служба System Restore отключена.

UPD2. Запускали на другом компьютере. Тот же результат, сама среда грузится. При попытке загрузить скетч - Launch4j - an error ocurred while starting the application.

Andrey_Y_Ostanovsky
Offline
Зарегистрирован: 03.12.2012

Скачал nightly_build, он про себя говорит, что 1.6.0, простейший скетч (без инклюдов) - скомпилировался и не упал. Ставить его вместо основного бинаря пока стремно, т.к. с этой джавой всегда масса граблей с раскладыванием ее потрохов в соответствии с фэншуем разработчиков.

Т.е., дело не в сборках, а что-то в конкретной машине.

~$ java -version
java version "1.7.0_65"
OpenJDK Runtime Environment (IcedTea 2.5.3) (7u71-2.5.3-0ubuntu0.14.04.1)
OpenJDK Client VM (build 24.65-b04, mixed mode, sharing)

Maverik
Offline
Зарегистрирован: 12.09.2012

попробуйте после неудачного запуска убивать процесс javaw

selevo
selevo аватар
Offline
Зарегистрирован: 21.12.2013

решения два:

1. отключить в диспетчере  все виртуальные  bluetooth COM порты

2. и как отмечалось  снать сглаживание.

Looka
Offline
Зарегистрирован: 24.04.2012

У меня ошибка возникла на старых верссиях IDE.
Держу 1.0.6  для совметимости с Atmel Studio  ну и свежие версии.
Ошибка  вылезла при запуске 1.0.6 когда  прописал  путь к  скечам  новой верси.

Лечится переименованием  пути в свежих версиях.
IDE не найдет папку и проришет путь по умолчанию.