Не могу залить скетч на уну

Varlam-t
Offline
Зарегистрирован: 26.03.2019

При подачи питания через блок питания либо по юсб, то загораются диоды on и L и не гаснут. Диспетчер устройств видит уну ch340g (драйвер отдельно не ставил) а при заливке скетча вылазит ошибка. Помогите понять что это. Пытался вольтметром померить напряжение между 13 контактом и GND который рядом, то диоды L гаснут. 

kriss
Offline
Зарегистрирован: 24.01.2014

Для чего измерять напряжение на 13  и главное каким прибором?    щупы прибора коротят? - режим измерения проверь.

 

Varlam-t
Offline
Зарегистрирован: 26.03.2019

Ну как я понимаю если горит диод L то и на 13 контакте должно быть напряжение. Измерение провожу обычным мультиметром с пределом -20В контакты острые, не корочу. Щупы вставлены в разъем для измерения напряжения. Если мерить 13 GND противоположный, то диод не гаснет напряжение 0.2в. забыл добавить, видемой реакции на кнопку ресет тесть диоды горят ровным светом

kalapanga
Offline
Зарегистрирован: 23.10.2016

На светодиоде тут нечего измерять, оставьте его в покое. А вот про последнюю строчку из сообщения выше уточните - реакции на кнопку ресет НЕТ ? Если так, то это неправильно. Она вообще нажимается, щёлкает? Может она продавлена и всегда замкнута? Прозвоните. Можно ещё спиртом плату помыть - что-то она на вид не особо чистая.

Varlam-t
Offline
Зарегистрирован: 26.03.2019

Кнопка нажимается нормально, с щелчком, прозвонил, при нажатии поевляется контакт на обоих парах контактов, по диагонали также. При отжатой кнопки разрыв. Что я ещё заметил в своей плате, это то что чип ch340 перпендикулярен кварцу, а у всех остальных параллелен. Я понимаю что кто как хочет так и производит компановку элементов, но я не нашел в интернете не одного такого изоабражения как у меня, и зачем китайцем выдумывать самокат. 

Если заработает протру, зачем зря спирт тратить.

Varlam-t
Offline
Зарегистрирован: 26.03.2019

При загрузке скетча, при попытках записи от 1 до 10 на каждую попытку диод RX промаргивает.

Если запустить плату и метить на кнопке напряжение, то в нормальном состоянии 5в, при нажатом 0в.

kalapanga
Offline
Зарегистрирован: 23.10.2016

Varlam-t пишет:

Если заработает протру, зачем зря спирт тратить.

Я имел ввиду, что может заработать, если протереть. Здесь на форуме можете найти не один случай, когда промывка "оживляла" плату. Вот мой личный http://arduino.ru/forum/apparatnye-voprosy/zagruzka-sketcha-v-leonardo  Но разумеется гарантии нет, что проблема в этом.

Squb
Offline
Зарегистрирован: 12.09.2016

1) Это новая плата и она не работает? - пробуйте залить загрузчик (http://arduino.ru/forum/obshchii/arduino-perezapisat-zagruzchik)

2) Эта плата раньше работала? - пробуйте залить загрузчик снова - не ппомогло проверяем питание, если оно впорядке, то наверное микроконтроллер умер(заменить).

xDriver
xDriver аватар
Offline
Зарегистрирован: 14.08.2015

может нужно програмировать old bootloader или возможно WAVGAT ?

Varlam-t
Offline
Зарегистрирован: 26.03.2019

Плата была куплена в начале 2016 года, но на сколько я помню также не получилось залить на нее скетч и я ее закинул. Лежала без дела. Щас понадобилось собрать схемку, а она брыкует( К сожалению у меня нет второй ардуины и программатора... Где мерить напряжение? И каково оно должно быть? Мерил кнопку в разрыв там -5V я так понимаю что плата питается нормально. Кто ее знает, может даже круче чем WAVGET, но на ней не одной такой надписи, только BETEMCU.CN и их брендовый знак. https://s.click.aliexpress.com/e/bkbxPX5u

 

Какое нормальное состояние диода L? Потухший?

Varlam-t
Offline
Зарегистрирован: 26.03.2019

Забыл сказать, протер плату спиртам, диод L какое-то время не загорался, но когда начал заливать скетч на строчке 4 из 10 он опять загорелся и проблема не ушла, зато плата чистая)