Не устанавливаются драйвера

VikS
Offline
Зарегистрирован: 29.12.2011

Приобрел Arduino Nano v3.0. На стационарный комп дрова поставились без проблем, опыт с миганием Д13 прошел успешно. Но вот не могу подружить Arduino с буком, постоянно ошибка - не удалось найти указанный файл. Как не пытался подсовывать ему дрова - исход один и тот же.

Кто с таким сталкивался? Help!

Diemon
Offline
Зарегистрирован: 18.11.2011

 какой файл не находит то

VikS
Offline
Зарегистрирован: 29.12.2011

При подсоединении к порту юсб ноут никак на это нереарует в отличии от стационарного. В диспечере задач в контроллерах шины  юсб появляется устройство с ошибкой - FT232R USB UART. Переустановка драйвера к нему заканчивается окном  "Это оборудование установить не удалось", в котором говорится что произошла ошибка при установке оборудования и  не удалось найти указанный файл. Какой файл именно - не сообщается.

Borack
Offline
Зарегистрирован: 02.05.2013

У меня та же проблема. Win 7 64, ноутбук HP Compaq 615, пытаюсь подсоединить  Uno r3 и 2560.

Ошибка при установке, не удается найти указанный файл, отключил проверку цифровых подписей драйверов уже?,

ничего не помогает. Ребята помогите пожалуйста, у кого была такая проблема, как вы ее решили? 

Andrey_Y_Ostanovsky
Offline
Зарегистрирован: 03.12.2012

Вероятно, напряжения на USB не хватает... Можно попробовать подключить через USB-хаб с внешним питанием.

Borack
Offline
Зарегистрирован: 02.05.2013

И через USB хаб подключал, и питание с блока подавал.

Проблема не в этом..(

Borack
Offline
Зарегистрирован: 02.05.2013

Как - нибудь можно связяться с "VikS"? Капк вы решили эту проблему..?

alex_r61
Offline
Зарегистрирован: 20.06.2012

Под "гемором"(Win7) обычно авто установка не проходит. Надо устанавливать вручную

с указанием пути к драйверам.

Borack
Offline
Зарегистрирован: 02.05.2013

Это очевидно, Я все это делал, и вручную кликая по "Неизвестное устройство", и "Добавить устаревшее устройство", указывая что устройство висит на COM. Все бесполезно.

"При установке произошла ошибка, не удается найти указанный файл"....(

В общем, c записями в *.Inf ошиок быть не может,  и с виндой не должно быть чего-то битого. Я подключал к этому ноуту два DMM 4050, через их фирмовый USB => COM. Ставил их драва, и все отлично отработало. Ума не приложу, в чем дело .....

Переустанавливать из -за этого винду не резон, там стока настроенного софта, мама не горюй, диск SSD, и винда настроена под него специально. Я ужо даже не пререустанавливаю ее, просто периодически делаю Acronix image manager_ом образы, и при падении или еще чем, восстанавливаю, потому как полная переустановка замет двое суток возьни. Так что, ребята, кто может, посоветуйте, очень надо.

Я дипломный проект делаю, дуина с ноута, "вот так" нужна... Пожалуйста.

 

 

Snubist
Offline
Зарегистрирован: 18.02.2013

А  драйвера с http://www.ftdichip.com/Drivers/VCP.htm непробовал?

Borack
Offline
Зарегистрирован: 02.05.2013

В UNO R3 и 2560 нет FTDI, связь по USB осуществляется через ATmega8U2

BeeLove
Offline
Зарегистрирован: 17.06.2014

Целый день убивал этот вопрос. Удалось приростить arduino nano v3. Вот ссылка на драйвер.

232_pl-2303-win7-8(32-64bit).zip

Вот ссылка на статью: http://www.kochetov.net.ua/?p=518

Siraam
Offline
Зарегистрирован: 26.07.2014

Я совершенно новый чайник в Ардуине. Приобрел Ардуино Уно, подключил к компу, собрал 3 пример из книги и все работало нормально.Оставил наночь подключенным к компьютеру, а на следующий день не работает. Показывает что СОМ3 не найден. Открыл менеджер устройств и там показывает ошибку драйвера "Другое устройство". Попытка исправить драйвер ни к чему не приводит. Думал что мой ардуино накрылся и купил другойю Картина та же самая. Ва чем может быть проблема?

 

BeeLove
Offline
Зарегистрирован: 17.06.2014

Можно пойти методом исключений, первый шаг вы сделали, убедились, что причина не в Ардуино. Значит комп. Попробуйте в диспетчере устройст полностью удалить драйвер. Потом установить его из пакета программирования ардуино. Там папка есть драйвера. Ставите оттуда и снова подключаете ардуинку, смотрите появилось ли нормальное устройство.

Siraam
Offline
Зарегистрирован: 26.07.2014

Спасибо, такая папка есть только обьсните куда их ставить?

Borack
Offline
Зарегистрирован: 02.05.2013

VK.com/borack пишие - разъясню..

(Оч. много работал с Ардуино в качестве быстрого прототипирования)

Понадобилось - собрал написал, в основном для ллабораторного проектирования.

BeeLove
Offline
Зарегистрирован: 17.06.2014

Откройте диспетчер устройств, правой капой мыши на неработающем устройстве, обновить драйвер, вручную, указываете эту папку и ставите галочку шарить в подпапках, она сама найдет что надо. Попробуйте, скажите результат.

Siraam
Offline
Зарегистрирован: 26.07.2014

Благодрю. Как я раньше не додумался, вернее пробовал но выбрал только одну подпапку. Поставил на папке дврйвера и все пошло Кщк раз большое спасибо Теперь можно экспепиментировать со солнечным трекером

prepodavatel
Offline
Зарегистрирован: 07.02.2014

Сегодня я столкнулся с этой проблемой. Измучался, но нашел решение. Я даже оформил подсказку: https://yadi.sk/i/bV179qFjdMdpE Буду рад, если она поможет кому нибудь!

Kresnik
Offline
Зарегистрирован: 16.08.2014
prepodavatel
Offline
Зарегистрирован: 07.02.2014

Спасибо вам, уважаемый Kresnik!!!

Я восстановил все свои Нанки. Они посыпались все на Windows 7, хотя на нем отключены все обновления! Глубокий вам поклон до земли!!!

ADR
Offline
Зарегистрирован: 13.09.2016

Вдруг исчез нормальный драйвер для Uno. Установка/переустановка ничего не дала.

Единственное что помогло - установка драйвера по ID устройства. У меня USB\VID_1A86&PID_7523&REV_0254

драйвер https://drive.google.com/file/d/0B5okZr5AW4gaX2pZaWt6dVNaSFU/edit

Jeka_M
Jeka_M аватар
Offline
Зарегистрирован: 06.07.2014

Это драйвер не для оригинальной UNO, а для китайского клона UNO с китайским USB-UART преобразователем.

Цитата:

Единственное что помогло - установка драйвера по ID устройства. У меня USB\VID_1A86&PID_7523&REV_0254

Достаточно было посмотреть на название микросхемы USB-UART преобразователя - CH340G.

P.S. Всегда берите драйвера из первоисточника - с сайта производителя.

ADR
Offline
Зарегистрирован: 13.09.2016

Спасибо. Странно, что 2 разных компьютера, с разными ОС, нормально работали с драйверами из комплекта поставки Arduino IDE. Потом поставил на ноутбук - не определяется порт. Плюнул пошел за комп - и там уже не определяется...

Jeka_M
Jeka_M аватар
Offline
Зарегистрирован: 06.07.2014

ADR пишет:

Странно, что 2 разных компьютера, с разными ОС, нормально работали с драйверами из комплекта поставки Arduino IDE.

Вот это действительно странно, т.к. в комплекте поставки Arduino IDE нет драйверов для CH340G. По крайней мере раньше точно не было, приходилось ставить их отдельно.

Artembuzz
Offline
Зарегистрирован: 29.11.2017

Тут еще вариант фикса

https://arduino-kit.ru/catalog/id/arduino-uno-r3-ch340

mostApi
Offline
Зарегистрирован: 29.05.2017

Нужна помощь, приобрел на Али плату: Crowduino m0 на чипе Atmel ATSAMD21G18A-U, после определения при установке драйверов плата вызывает BSOD (синий экран) системы - может кто знает что можно сделать?

Китайский мастер продавца говорит перезалить загрузчик - как это можно сделать, если плата вызывает BSOD?