Делаем дозиметр!

Muxi
Offline
Зарегистрирован: 22.01.2019

Все поправил, кнопки работают, все остальное тоже

Накачка 4, напряжение 401. Скорость 68-70

Скажите, какая оптимальная скорость должна быть? какие факторы на нее влияют?

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Сопротивление делителя, трансформатор, конденсаторы в первичке, в целом выполнение ВВ части, напряжение питания, частично уровень фона. 70 при работе от аккума нормально.

Muxi
Offline
Зарегистрирован: 22.01.2019

Если еще один виток добавить, что изменится? Намотано где-то 3.5витка проводом 0.5мм

Делитель 131.6М / 99.6К, гантелька RLB1314-103KL + 3.5 витка 0.5мм, по входу стоит тантал 39мF + 100nF керамика, на выходе 0.1мF. Питается пока от усб (5.1в)

 

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Пробовать надо. Основной параметр оптимизации - уменьшение тока потребления узлом преобразователя, но чтобы скорость при этом особо не увеличивалась. 

Для пяти вольт скорость 70 многовато.

Тантал заменить на керамику. Толку будет намного больше, чем от изменения трансформатора.

Muxi
Offline
Зарегистрирован: 22.01.2019

Хм, завтра попробую, спасибо

blokerun2
Offline
Зарегистрирован: 27.01.2019

Проблема в настройке ВВ преобразователя. Сделал схему на голом Atmega328p. Не могу вытянуть напряжение. Трансформатор- гантелька 10 мГн, первичка 4 витка ПЕВ-0,5. Конденсаторы - керамика 2х10 мкф. Вначале на выходе было 75 В, поменял местами концы первички, стало 245 В. На любом значении накачки, хоть 5, хоть 200.  Общий ток потребления девайса 40 мА. С отключенным ВВ преобразователем ток 9 мА. Резистор в цепи питания ВВ преобразователя 51 Ом. Куда копать?

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

245 по системному или внешнему вольтметру? Фото собранного девайса и системного меню? Транзистор и диод рекомендованные? С коэффициентами делителя не ошиблись?
Резистор можно уменьшить до 20-30.

blokerun2
Offline
Зарегистрирован: 27.01.2019

Напряжение 245 В и по внутреннему и по внешнему вольтметру. Диод UF4007, ВВ конденсатор 0,1 мкф, транзистор не помню какой заказывал, или IRLML2502 или IRLML6346. Коэффициент правильный, потому что совпадают показания внутр. и внешнего вольтеметра. Может не подходит гантелька?

Гантельку пока припаял с обратной стороны платы, пока наладка идет.

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Накачку подбирайте в диапазоне 1-20, выше не стоит. Надо будет в следующих версиях ограничение поставить.
Я так понимаю, что внешний вольтметр в процессе настройки подпаян постоянно?
Резистор убавьте до 20-30.
Скетч ковыряли? Gif.c соответствующей версии брали? А то системное меню на фото из себя кашу представляет, так быть не должно.
Счётчик тоже до окончания настройки ставить нельзя.
Зачем два диода на ВВ части?

dennas
Offline
Зарегистрирован: 29.08.2018

Привет, собрал тоже себе дозиметр. Скетч использовал 1.08. Катушка - купить дроссель-гантельку на 10мГн и намотать поверх 4 витка провода. Остальное все по схеме, заисключением вместо 100 кОмR18 воткнул на 220кОм. Запустился работает. Возник вопрос - сколько должно быть скорость импульсов у меня 163-167 накачка 397, это нормально? Тут читал что скорость должна быть в пределах 30-150

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Многовато, но работать должно. Коэффициенты делителя пересчитали? Чтение напряжения откалибровано?

dennas
Offline
Зарегистрирован: 29.08.2018

Тут  читал что скорость должна быть в пределах 30-150. ADC 146 я его даже чуть меньше делал Коэффициент 637

dennas
Offline
Зарегистрирован: 29.08.2018

ADC ставил 136

dennas
Offline
Зарегистрирован: 29.08.2018

Чтение напряжения откалибровано? Пока нет примерно мерел просадка до 185 была, жду когда привезут другой тестер. Выставил на 397-400В.

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Откалибровать желательно. Работать будет и при такой скорости. Конденсаторы в первичке преобразователя керамика? Когда при замере на мультиметре было 185, с показаниями в системном меню совпадало?

dennas
Offline
Зарегистрирован: 29.08.2018

Конденсаторы керамика везде. ПРизамере на мультеке показало 185, в системе уже не помню, где то в педелах 280-300 было, изначально конденсатор был С3 - 0.1 на 400 сейчас поставил на 630В тогда не было. А так да дозик работает считает)

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Повторите замер. Если разброс показаний мультиметра и системного меню более десяти процентов, то либо плата плохо отмыта, либо в делителе/коэффициентах ошибка.

dennas
Offline
Зарегистрирован: 29.08.2018

Ясно, подожду когда привезут мультик. Спасибо.

Сейчас пробывал выставил в системе накачку на 6 - 397 стабильно, скорость импульса стала 97-100, фон показывает такой же как на дозиметре мастер1.

Arezus
Arezus аватар
Offline
Зарегистрирован: 26.06.2013

Blokerun2, у Вас абсолютно отчаянно припаяна гантель, вероятность пробоя в низковольтную часть капец шкалит. Да и расположение пятаков под гантель слишком плотное, очень отчаянно. Резисторы делителя я бы тоже отогнул от трубки. По поводу низкого напряжения — очень похоже, что у Вас мультиметр шунтирует цепь. И зачем на плате два диода в послед?

blokerun2
Offline
Зарегистрирован: 27.01.2019

Arezus пишет:

Blokerun2, у Вас абсолютно отчаянно припаяна гантель, вероятность пробоя в низковольтную часть капец шкалит. Да и расположение пятаков под гантель слишком плотное, очень отчаянно. Резисторы делителя я бы тоже отогнул от трубки. По поводу низкого напряжения — очень похоже, что у Вас мультиметр шунтирует цепь. И зачем на плате два диода в послед?

Мультиметр не подсоединен постоянно, только кратковременно для контроля. На счет близкого расположения пятаков- согласен, но пока не "шьет" )). Диоды последовательно поставил- начал было делать умножитель но передумал потом. Буду пробовать другие трансформаторы, думаю гантелька слабенькая...

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Так что с прошивкой? Залита явно некорректная.

Arezus
Arezus аватар
Offline
Зарегистрирован: 26.06.2013

Blokerun2, может что-то другое шунтирует или у Вас мультик с гигаомным сопротивлением? Просто должна быть разница по напряжению с подключенным и отключенным мультиком. Номиналы резисторов в делителе проверьте, может чужак затесался. У меня гантель похожих габаритов,  страницу-другую назад выкладывал фото. Гантель 8х10, 9мГн, 7 Ом. А какое сопротивление вторички на гантельке?

Samodelkin_YouTube
Offline
Зарегистрирован: 16.12.2018
Друзья привет. Хочу вернуться к датчику СИ22Г.Чувствительность к излучению по Cs-137 = 228 имп/мкР  , а по Co-60 = 540 имп/мкР. Поэтому получаем разное время счета Cs-137 = 15.7 с. ,Co-60 = 6.7 с. 
Возникает вопрос сколько секунд должен длиться счет? Также в СИ22Г есть собственный фон, и он составляет 1.25 ип/ сек. 
Поэтому думаю нужно добавить в прошивку коррекцию погрешности собсвенного фона, например каждые 0.8 секунды отнимать один импульс.
Тогда можно будет подобрать время счета так чтобы он показывал естественный фон,или опираться на показания другого прибора.
Можно ли что-то такое сделать?
Arezus
Arezus аватар
Offline
Зарегистрирован: 26.06.2013

Расскажу как проблема собственного фона решена в радиометре СИМ-05. Там преобразование идет не как в Припяти и иже с ней, накачкой кондера и индикацией напряжения на нем после преобразования, там стоит счетный каскад на каждый разряд, датчика два, обернутых свинцом, время замера в режиме «Поиск» - 20 сек. Так вот, на плате стоят места под перемычки, которыми задается начальное состояние счетчика младшего разряда, нога направления счета стоит в реверсе, в начале счета идет уменьшение значения счетчика до ноля, в этот момент направление счета меняется на суммирование и пошло накопление вверх. По истечению 20 сек счетчики переносятся через регистр на ЖКИ и сбрасываются в начальное состояние фона датчиков. Индикация замирает до следующего конза замера, тк буффер не сбрасывается, он обновится только по истечению 20 сек. Поэтому можно обойтись малой кровью и тут, показания фона уменьшать до нуля, затем накапливать показания замера, только потом полученный результат добавлять в усреднение.

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Samodelkin_YouTube пишет:
Чувствительность к излучению по Cs-137 = 228 имп/мкР , а по Co-60 = 540 имп/мкР. Поэтому получаем разное время счета Cs-137 = 15.7 с. ,Co-60 = 6.7 с. Возникает вопрос сколько секунд должен длиться счет?
Что собрались измерять - по том и градуируйте.

Samodelkin_YouTube пишет:
Также в СИ22Г есть собственный фон, и он составляет 1.25 ип/ сек.
Не составляет, а не превышает. В реальности может быть на порядок-два меньше. Добавлять же в качестве компенсации максимальное значение - заведомо ухудшить результат. Желаете приблизительно узнать значение для своего экземпляра? Камера из свинца со стенками сантиметров десять, облицованная изнутри медью и пластиком, и можно измерять ))

Тестовую прошивку под этот датчик я выкладывал. Есть желание - допиливайте график и разностный замер.

blokerun2
Offline
Зарегистрирован: 27.01.2019

tekagi пишет:
Так что с прошивкой? Залита явно некорректная.

Да, перезалил прошивку- отображается всё корректно. Но напряжение не поднимается. Гантеля не та наверное. Вместо ВВ диода сделал умножитель как на рисунке (номиналы не смотрите, они на схеме готовой были). В итоге- напряжение: 410 В, накачка: 13, скорость накачки: 165. Пока так побалуюсь.

blokerun2
Offline
Зарегистрирован: 27.01.2019

Arezus пишет:

Blokerun2, может что-то другое шунтирует или у Вас мультик с гигаомным сопротивлением? Просто должна быть разница по напряжению с подключенным и отключенным мультиком. Номиналы резисторов в делителе проверьте, может чужак затесался. У меня гантель похожих габаритов,  страницу-другую назад выкладывал фото. Гантель 8х10, 9мГн, 7 Ом. А какое сопротивление вторички на гантельке?

Так напряжение меняется , если подключаю тестер (у меня советский Ц4354). Падает с 245 В до 190 В примерно, и внутренний вольтметр тоже показывает 190 В. Так что с делителем всё ОК. Гантелька 10 мГн, сопротивление 13-14 Ом. Я предполагаю что на ней нет 600 витков а меньше, поэтому коэфициент трансформации низкий.

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Странно как-то преобразователь себя ведёт. Как-будто что-то ограничивает уровень импульса. Может шить гантельку внутри, или у транзистора малое допустимое напряжение. Или всё же сказывается минимальный зазор между полигонами под гантельку и дорожкой, там желательно хотя бы миллиметр.
Токоограничивающий резистор уменьшить пробовали? Какое напряжение на керамике?

blokerun2
Offline
Зарегистрирован: 27.01.2019

Напряжение на керамике 2,8 В. Резистор ограничивающий уменьшал до 27 Ом, поднялось напряжениес 245 до 280 В. Прислушивался к гантельке, вроде еле заметный треск слышен, может в натуре "шьёт" высоким? Но тогда бы напряжение на вольтметере сильно скакало?

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Потрескивание и будет, это нормально, там амперы в коротких импульсах.
Токоограничивающий резистор уменьшить пробовали?
Какое напряжение на керамике?
Что на выходе при уровнях накачки от 1 до 10?

blokerun2
Offline
Зарегистрирован: 27.01.2019

tekagi пишет:
Потрескивание и будет, там амперы в коротких импульсах. Токоограничивающий резистор уменьшить пробовали? Какое напряжение на керамике? Что на выходе при уровнях накачки от 1 до 10?

Напряжение на керамике 2,8 В (при ограничивающем резисторе 51 Ом). Резистор ограничивающий уменьшал до 27 Ом, поднялось ВВ напряжение с 245 до 280 В. При уровне накачки от 1 до 10 напряжение меняется от 230 до 240 В. Максисмум при уровне 13 - 245 В.

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Хм. Пока можно попробовать убрать полвитка-виток первички и добавить ещё один-два керамических конденсатора к установленным. Если не поможет, то, скорее всего, менять или перематывать транс. Хотя пока с подобными гантельками особых проблем не возникало.

Резистор в цепи затвора полевика часом не проволочный?

Dark-Dante
Offline
Зарегистрирован: 09.01.2018

У меня точно такая же гантелька и никаких проблем с напряжением нет. Резистор на 20 Ом, вроде, не помню уже.

Muxi
Offline
Зарегистрирован: 22.01.2019

tekagi пишет:
Тантал заменить на керамику. Толку будет намного больше, чем от изменения трансформатора.

Заменил на 20mF керамики, скорость упала до 35!

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Muxi, а потребление преобразователем?
alexadresat, сколько прибор на одном заряде продержался? Или ещё в работе? И какая фактическая ёмкость аккумулятора?

Muxi
Offline
Зарегистрирован: 22.01.2019

tekagi, с ардуино  led не выпаивал, дисплей без подсветки - 20mA

Dark-Dante
Offline
Зарегистрирован: 09.01.2018

Много, у меня 11-12 с подсветкой, но у меня и не ардуино.

Muxi
Offline
Зарегистрирован: 22.01.2019

Dark-Dante, это при 5.1в, куда копать? еще виток добавлять к трансу?

alexadresat
alexadresat аватар
Offline
Зарегистрирован: 22.02.2017

 Двое суток держит, приостоянно включена подсветка экрана и индикация звук+свет.

3.22V, высокое 372V, скорость 510 имр/сек. Дозиметр вырубился по нарряжению 2.75V.

Muxi
Offline
Зарегистрирован: 22.01.2019

В чем может быть проблема, при питании 5 в, все ок работает, переходишь на литий (3.88) после включения сразу переходит в меню (где пороги и подсветка) выходишь, а он через секунду опять заходит туда же... Ардуина не хочет работать нормально от такого наряжения?

alexadresat
alexadresat аватар
Offline
Зарегистрирован: 22.02.2017

Arduinо надо на питание 3.3V (Модуль Mini ATMEGA328 3,3 В 8 мГц )

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Возможно аккумулятор не ахти. Добавка по питанию хорошего электролита с низким esr на несколько сотен микрофарад не помогает? Акк подключен правильно, между vcc и gnd?
Alexadresat, не путайте народ, ардуинка в проекте 5/16. 3,3/8 теоретически поддерживается, с явным указанием дефайна, но там надо стаб и диоды сдувать, плюс сложнее накачку настроить.

Muxi
Offline
Зарегистрирован: 22.01.2019

alexadresat, так в 23м посте написано, что надо на 5в

Dark-Dante
Offline
Зарегистрирован: 09.01.2018

alexadresat, разряд до 3х Вольт, напряжение 400, скорость 190. У вас не тащит преобразователь уже раз скорость 510, а если еще и фон будет не в норме?

alexadresat
alexadresat аватар
Offline
Зарегистрирован: 22.02.2017

Фон немного занижает 6-12 мкр/ч.

alexadresat
alexadresat аватар
Offline
Зарегистрирован: 22.02.2017
Muxi
Offline
Зарегистрирован: 22.01.2019

tekagi пишет:
Возможно аккумулятор не ахти. Добавка по питанию хорошего электролита с низким esr на несколько сотен микрофарад не помогает? Акк подключен правильно, между vcc и gnd?

Перебрал уже несколько банок 18650, если успеть перейти в другое меню, то показывает VCC 4.05, накачка 4 / 401 и скорость 40.

Но только стоит выйти на главный экран через доли секунды перекидывает в меню настройки порогов.

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

alexadresat, хз как себя поведёт рандомный китайский стаб при подаче завышенного напряжения в обратку. А так - мега та же. Только дефайн раскомментировать. И светики сдуть.
Muxi, подключён акк верно? Ардуина какая? Фото и файл печатки? Кнопки по плате как разведены? Подтяжки стоят?

alexadresat
alexadresat аватар
Offline
Зарегистрирован: 22.02.2017

Китайца пишет - Вход постоянного тока 3,3 В до 12 В

tekagi
tekagi аватар
Offline
Зарегистрирован: 07.10.2016

Угу, на вход Vin. Если больше 5 подать на vcc - можно увидеть, как 2$ превращаются в волшебный дым. А если встроенный стаб боится обратки - то и при 4-5V.