несовместимость 1.6.6 и библиотеки LiquidCrystal_I2C.h

Нет ответов
inspiritus
Offline
Зарегистрирован: 17.12.2012

Здраствуйте

пользую в некоей программе на нане с расширителями PCF8574 для экрана и матричной клавиатуры,  библиотеку

#include <LiquidCrystal_I2C.h>  //для экрана

все работало , вгруженное еще во времена IDE версии 1.0.5

потребовалось внести изменения в код, внес, скомпиллировал, и залил с IDE 1.6.6 ....

экран выводит только по первому символу из аргумента функции .print(); , чтобы вывести строку необходимо для каждого символа вызывать  .print();

чуть было за паяльник не схватился... вовремя одумался, скомпилил и загрузил из-под старой IDE , все заработало.

Вот и верь после этого ....