LCD-индикатор

Saint_Bernard
Offline
Зарегистрирован: 25.03.2011

Есть LCD индикатор 16х2 EL-1602A. Подключаю к ардуино по правилам, указанным в стандартных скетчах. Загорается только синим цветом, а символы не выводит. В чем может быть проблема?

Adessit
Adessit аватар
Offline
Зарегистрирован: 12.04.2011

Первое и самое главное проверить схему подключения. У самого такая была история. 2. Покрутить контраст напеременнике. 3. Земля экрана не связана с ардуино. Вобшем выложите фотографии полного подключения. Я подключал в соседней теме экран и всё тип топ со второго раза arduino.ru/forum/obshchii/27vt-svetodiodov-3-po-3vt-kazhdogo-tsveta-rgb-signal-muzykalnyi-na-analogovyi-vkhod

Saint_Bernard
Offline
Зарегистрирован: 25.03.2011

А еще такой вопрос, в моем экранчике контроллер KS0066, а библиотека Ардуино написана под HD44780. В этом может быть проблема? Хотя, эти контроллеры совместимы, интерфейс дисплеев и на тех и тех  абсолютно одинаковый. 

Adessit
Adessit аватар
Offline
Зарегистрирован: 12.04.2011

Контроллер тот же. Всё тоже самое.главное не ошибиться при подключении. Я себе сделал вот по такой инструкции :arduino.cc/en/Tutorial/LiquidCrystal Будут вопросы пишем не стесняемся

anton_kulibin
Offline
Зарегистрирован: 28.10.2012

 у меня uno и 1602 а, все подключил работает тольо выводит иероглифы пробовал только латиницей.

Заметил такую закономерность, после простоя без питания й подключения Arduino к питанию на LCD показывает то что нужно

iwizard7
iwizard7 аватар
Offline
Зарегистрирован: 30.04.2013

Adessit пишет:

Первое и самое главное проверить схему подключения. У самого такая была история. 2. Покрутить контраст напеременнике. 3. Земля экрана не связана с ардуино. Вобшем выложите фотографии полного подключения. Я подключал в соседней теме экран и всё тип топ со второго раза arduino.ru/forum/obshchii/27vt-svetodiodov-3-po-3vt-kazhdogo-tsveta-rgb-signal-muzykalnyi-na-analogovyi-vkhod

А можно поподробнее о подключении, а то ссылка уже не активна, а проблема такая же как у топикстартера, только у меня еще и подсветка не горит, Только видно что символы в верхней строке поностью закрашены