не могу подключить Arduino Nano 3.0 к Windows 8.1

pg81
Offline
Зарегистрирован: 05.06.2015

1.Скачал дрова http://forum.amperka.ru/styles/default/xenforo/gradients/category-23px-l...) 50% 0% repeat-x rgb(255, 244, 229);" target="_blank">http://www.arduino.cc/en/Main/Software

ардуино стала определяться как устройство FT232R USB UART

2.наткнулся на статью http://did5.ru/arduino/vosstanavlivaem-arduino-nano.html думал PID на 0000 поменялся

проверил все ок

3.Скачал дрова с этой страницы как указано в статье http://www.wut.de/e-3wwww-51-inus-000.php

установил их в ручную

4.Теперь вроде видена плата USB Serial Port (COM3)

5.Пытаюсь залить простой скетч выдается сообщение

avrdude: ser_open(): can't open device "\\.\COM3": Отказано в доступе.

Проблема загрузки на плату. Для достижения дзен, куритьhttp://www.arduino.cc/en/Guide/Troubleshooting#upload .
Ошибка открытия последовательного порта "COM3" (Port busy)


Подскажите что делать, куда смотреть, что почитать, ничего не могу найти на эту тему.
Во многих темах пишут, что все на винде 8.1 все хорошо само ставится.

superaft
Offline
Зарегистрирован: 13.02.2015

Попробуй во время прошивки на кнопку reset нажать, на сколько мне известно конверторы от ftdi страдают тем, что автомвтом не сбрасывают МК.

Andrey_Y_Ostanovsky
Offline
Зарегистрирован: 03.12.2012

pg81 пишет:
avrdude: ser_open(): can't open device "\\.\COM3": Отказано в доступе.

Как правило, это говорит о том, что либо устройства нет (а Ваше устройство если и "висит" в системе, то на другом номере), либо прав у пользователя на работу с этим устройством нет.

pg81
Offline
Зарегистрирован: 05.06.2015

Знаю такую проблему, reset нажимал. 

pg81
Offline
Зарегистрирован: 05.06.2015

А что можно предпренять, если устройство висит на другом номере?

Или если нет прав. Не знаю как проверить два этих предположения

trembo
trembo аватар
Offline
Зарегистрирован: 08.04.2011

(Port busy)  

Его уже кто-то юзает

Поменяйте вручную номер этому порту  на, например,  десятый. Поменяется? Появится в системе? ИДЕ увидит этот порт?

pg81
Offline
Зарегистрирован: 05.06.2015

Порт уже менял, но при смене на любой другой пишет, что он занят другой программой. Я всеравно меняю, но это не помогает

superaft
Offline
Зарегистрирован: 13.02.2015

Попробуй старый драйвер через диспетчер устройств снести и поставить новый с официального сайта поставить http://www.ftdichip.com/Drivers/VCP.htm

Andrey_Y_Ostanovsky
Offline
Зарегистрирован: 03.12.2012

pg81 пишет:
Порт уже менял, но при смене на любой другой пишет, что он занят другой программой. Я всеравно меняю, но это не помогает

Платформу менять надо... Возьмите какой-нибудь liveCD с линуксом и попробуйте там.

pg81
Offline
Зарегистрирован: 05.06.2015

попробовал на другом ноуте с WinXP, все получилось и поставилось. 

НО это не отменяет моего вопроса, мне всеравно хочется на винде 8 чтобы заработало

superaft
Offline
Зарегистрирован: 13.02.2015

Попробуй преустановить IDE на самую новую, запустить от имени администратора, проверь правильно ли плата в настройках выбрана

Puhlyaviy
Puhlyaviy аватар
Offline
Зарегистрирован: 22.05.2013

Я удивляюсь, как у вас так выходит... у меня 8.1 и все нормально автоматом дрова встали... нафига лезть куда то качать всякое непонятное, потом гонять вирусы пару дней... что за мазахизм такой.
Кто то уже использует этот порт... кто?

pg81
Offline
Зарегистрирован: 05.06.2015

Ну дрова я скачивал с официального сайта, по идее вирусов не должно быть.

А после установки сами дрова не установились и плата определилась как устройство FT232R USB UART. Поэтому пришлось устанавливать вручную. Кто занял сом порт не знаю как определить. По идее если бы плата была поддельная, то PID сбросился бы на 0000 (как в вычитал в этой статье http://did5.ru/arduino/vosstanavlivaem-arduino-nano.html), но он не сбросился. 

Но дрова сами не встали и сом порт занят. Причем все заняты (пробовал менять на другие). Может фаервол все занял? хз. Пока  нет идей. На ХР все работает. Причем с теми же дровами.

Andrey_Y_Ostanovsky
Offline
Зарегистрирован: 03.12.2012

pg81 пишет:

попробовал на другом ноуте с WinXP, все получилось и поставилось. НО это не отменяет моего вопроса, мне всеравно хочется на винде 8 чтобы заработало

Вы не совсем верно трактуете: "хочется чтобы на этом железе и под Win8 заработало". Для этого и надо провести диагностику железа отдельно от операционки. Да хоть XP туда временно поставьте и проверьте... Может оно с Вашим USB не работает...

sadman41
Offline
Зарегистрирован: 19.10.2016

Подниму старую тему, чтобы в кучке лежало...

После обновления Win7 (сделал как раз перед получением проблемы, но до этого комп. стоял две недели невключаемый) словил ser_open(): can't set com-state for "\\.\COM3". Ардуина (Freeduino) проверенная временем, чип FTDI, кабеля те же, что и были. Другой софт не обновлял и т.п. и т.д. Порт появляется/исчезает при выдергивании кабеля. RX/TX без паразитных присоединений. Вобщем, всё чин-по чину, только ничего не работает. Голову чесал, другой софт запускал - занят порт и хоть тресни. Всякие антивирусы отключал, систему перезагружал, монитор протирал...

С горя полез смотреть в диспетчере задач свойства USB Serial Converter - ничего подозрительного, только версия драйвера лохматая - наверное как автоматом в первое подключение Ардуины три года назад поставилась... По привычке тыкнул в "Обновить драйвер" (с автопоиском) - винда куда-то полезла, что-то от августа 2017-го года скачала и... бинго! Скретчи шьются, скротчи тоже. Лампочки весело моргают, все рады и счастливы.